Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  • Java 8 is no longer supported
  • PostgreSQL 9.5 (9.5, 9.5.1) is no longer supported.

  • Microsoft SQL Server 2014 is no longer supported

  • Support for MySQL and MariaDB is deprecated. Those databases will be supported for some time (possibly long time), but support for them will be eventually removed. It is strongly recommended to use PostgreSQL instead.

  • Microsoft Active Directory 2008R2 is no longer supported.
  • Microsoft Windows Server 2008R2 is no longer supported.
  • Support for .NET remote connector server is deprecated.
  • SOAP-based IDM Model Web Service Interface is deprecated and it will be removed in midPoint 4.2. Please use RESTful interface instead.
  • Support for Apache Tomcat 8.5 is deprecated.
  • Explicit deployment to an external web container is deprecated.
  • MidPoint plug-in for Eclipse IDE was never officially supported. Despite that, it now has a deprecated status. The plan is to replace Eclipse with IntelliJ IDEA environment eventually.
  • Unofficial option to use Spring Security modules is no longer available. It was replaced by flexible authentication mechanisms.
  • Unofficial JasperSoft Studio plugin for midPoint is no longer available. There is no plan to make it available again.
  • Public API things - copy from https://github.com/Evolveum/midpoint/commit/882a2ceb03294affbf589f077102a9f519bbcea8 (select relevant methods).
  • The tolerant=false setting for items in object templates is no longer supported. This was an experimental feature from its conception in 2015, and was later superseded by the concept of mapping range. So, please migrate your configurations to use mapping range. You would most probably need predefined=all setting. It has approximately the same effect as tolerant=false  setting.

Releases Of Other Components

...