Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  • User interface improvements
  • Data model improvements
    • Full implementation of subType property
    • TODO: locality, etc.
  • Security improvements
  • Provisioning
  • Performance and scalability improvements
    • TODO
  • Miscellaneous improvements
    • Improved handling of function library updates
    • Minor mapping improvements
    • Improved SMS gateway support (HTTP POST method)
  • Connectors
    • CSV connector supports script execution
    • Active Directory connector supports CredSSP version 5 and 6 (see CVE-2018-0886)

Oracle database 11g is no longer supported. It is replaced by Oracle 12c database support.
PostresSQL 8.4.x is no longer supported.
MySQL 5.6 family is no longer supported.
Microsoft SQL 2008 and 2008 R2 are no longer supported.
Old CSVFile Connector is deprecated and it is no longer bundled with midPoint.

...

ComponentVersionDescription
ConnId1.4.3.11ConnId Connector Framework
LDAP connector bundle1.5.16LDAP, Active Directory and eDirectory connector
CSV connector2.2Connector for CSV files
DatabaseTable connector1.4.2.0Connector for simple database tables

...

  • The LDAP connector and AD Connector were upgraded to the latest available version.  The reason is a vulnerability in CredSSP protocol version 4 and earlier (CVE-2018-0886). Microsoft implemented CredSSP versions 5 and 6 to mitigate the issue. However those versions are incompatible with previous versions, therefore new implementation has to be done in the connector.
  • CSV connector now supports script execution (executing operating system commands).

Behavior changes since 3.7 and 3.7.1

...