Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

The Question

Can I use a newer PostgreSQL database than that which is specified in release notes?

Can I use newer version of Active Directory than which is mentioned in connector documentation?

Can I use the most recent browser version with midPoint?

Short Answer

Yes, but do not be surprised if this will not be entirely smooth ride.

Long Answer

Our strategy is to support the most recent versions of databases, source systems, target systems, browsers and any other software components that we live with. That is the strategy. But there are practical limitations. It is not enough to just declare support for some particular version. The declaration itself is not a magic charm that make things works. What is needed here is testing. Lot of testing. And fixes for the bugs that might be found. That requires time.

If you are conservative and you want to be sure that you have completely supported solution and that we will fix any bugs that you might found please use the recommended version. And make sure you are covered by support agreement. We will not fix community issues related to a specif kind and version of a database or any other system. We will do that only for customers covered by support agreements.

If you like to live on an edge then go ahead and try a newer version. Especially if the component in question is an open source component with a good reputation, such as PostgreSQL. In that case it is very likely that your system will work smoothly. And if there are some minor issues, we will be more than happy to fix them (you still need support agreement, of course). Especially if you are a platform subscriber. However, there is still some danger. Some databases and systems have a bad habit to cause nasty problems when a newer version is used. This often happens with commercial components. In that case we still want to support the most recent version - eventually. But we might not be able to fix those issues in time for your project. We will try. But some of those issues may be too complex and may require major changes in the integration code. Many commercial products are notoriously difficult to predict. Therefore we cannot make any hard promises here.

Summary

If you feel like you want to try a newer version, please do so. Just make sure you are covered by support agreement or even better by platform subscription. If you run into problems we will do our best to help you. However, we cannot predict all the possible issues, therefore we cannot make any hard promises. Therefor please make sure you have a "plan B" to roll back to a supported version of the component in the worst case.

See Also

This document was moved to https://docs.evolveum.com/faq/new-versions/