Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  • Database schema needs to be upgraded using the usual mechanism.
  • Version numbers of some bundled connectors have changed. Therefore connector references from the resource definitions that are using the bundled connectors need to be updated.
  • Channel namespaces (and hence qualified names and URIs) were unified. This affects configurations where channel URIs are used, most notably flexible authentication configuration. Channel names need to be updated during the upgrade, otherwise the authentication may not work at all. When in doubt, it is recommended to disable flexible authentication (remove the configuration) before upgrade, conduct an upgrade with default authentication configuration, and re-enable the flexible authentication after upgrade (with new channel names). Channel name changes are documented below.
  • If you use custom version of starting script (normally bin/midpoint.sh) adjustments are needed, otherwise custom JARs in $MIDPOINT_HOME/lib will not be loaded to classpath. Consult the provided midpoint.sh, notice how -cp ... -Dloader.path=... and different main class are used.

Upgrade From MidPoint 4.0.x Or Older

...